EXTREME Overclocking Forums
Home | Reviews | Forums | Downloads | RealTime Pricing Engine | Folding Stats Contact Us


Go Back   EXTREME Overclocking Forums > Software Discussion > Linux, BSD, Alternative OS's

Welcome Guest Visitor! Please Register, It's Free and Fun To Participate!
The EXTREME Overclocking Forums are a place for people to learn how to overclock and tweak their PC's components like the CPU, memory (RAM), or video card in order to gain the maximum performance out of their system. There are lots of discussions about new processors, graphics cards, cooling products, power supplies, cases, and so much more!

You are currently viewing our boards as a "guest" which gives you limited access to view most discussions. You need to register before you can post: click the register link to proceed. Before you register, please read the forum rules. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own pictures, and access many other special features. Registration is fast, simple, and absolutely free! To start viewing messages, select the forum that you want to visit from the selection below.

After you have registered and read the forum rules, you can check out the FAQ for more information on using the forum. We hope you enjoy your stay here!

Note To Spammers: We do not allow unsolicited advertising! Spam is usually reported & deleted within minutes of it being posted, so don't waste your time (or ours)!


Please Register to Post a Reply
 
Thread Tools
Old 01-28-2012, 01:32 PM   #1
Orac
Master Shifu sees you
Orac's Avatar
Senior Member
 
Posts: 3,507
Last Seen: 09-28-2016
iTrader: 2 / 100%
Changing permisions

I am in the early thows of setting up a linux based server (using ubuntu 11.10 for time being).

i renamed the drive/partition using gparted, greated a mounting point using terminal

sudo mkdir /media/BackUp

right clicked the drive>mount. well i can access the drive with the termianl, (and do what ever i like in the GUI) but i can not make changes. i have been trying to figure out chmod, i cant find anything of any use whiel going through the ubuntu forum on how to do this, i have tried it a few way - most likely all wrong

cd /media
chmod =rwx /BackUp

cd /media/BackUp
chmod =rwx media/BackUp

and just about every variation of that.

i want to be able to access the BackUp drive from other machines, so setting permisions i am guesing is going to be important. and i want to get this sorted before i attempt to install smb.

i have just tried "sudo mkdir /media/BackUp/new_folder", it asked for a password, but there is no new folder there as far as i can see. it tell me "no such file or directory" if i ask for cd /media/BackUp/new_folder.

i am starting to see why people can frustrated with command code at first
United Kingdom  Offline
    Register to Reply to This Post
Old 01-29-2012, 12:51 PM   #2
UNIXgod
god of UNIX
UNIXgod's Avatar
Senior Member
 
Posts: 1,384
Last Seen: 01-09-2013
iTrader: 0 / 0%
http://www.javascriptkit.com/script/...chmodcal.shtml

Will this help. you can figure out the octals with it.
United States  Offline
    Register to Reply to This Post
Old 01-29-2012, 01:48 PM   #3
Orac
Master Shifu sees you
Orac's Avatar
Senior Member
 
Posts: 3,507
Last Seen: 09-28-2016
iTrader: 2 / 100%
thanks, that going in my favourites.

i re-formated the drive to ext3, and permision went strait over with sudo chmod.

i just trying to figure out samba now. i followed instruction on the ubuntu forum, but it is still unable to access window share, and typing the route to the server in windows (after giving it the correct ip) i get an invalid path result.

its getting late, and its been a long day so i will have another go tmrw when i can think strait
United Kingdom  Offline
    Register to Reply to This Post
Old 01-29-2012, 04:55 PM   #4
UNIXgod
god of UNIX
UNIXgod's Avatar
Senior Member
 
Posts: 1,384
Last Seen: 01-09-2013
iTrader: 0 / 0%
Here is a decent explanation of permission management.

http://catcode.com/teachmod/index.html

A common mistake is when a drive is not mounted the permission wont stay with just it's placeholder.

As for the samba issue it sounds like a network configuration problem.
United States  Offline
    Register to Reply to This Post
Old 01-30-2012, 03:48 AM   #5
Orac
Master Shifu sees you
Orac's Avatar
Senior Member
 
Posts: 3,507
Last Seen: 09-28-2016
iTrader: 2 / 100%
i think i am going to change my router any way, this BT one is ok, but no great
United Kingdom  Offline
    Register to Reply to This Post
Sponsored Links:
Please Register to Post a Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:30 PM.

Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by vBulletin
Copyright ©2000 - 2016, EXTREME Overclocking